Marc's Blog

Things from me about me …

IPTV on Bamboo with a Mikrotik router

| 4 Comments

Getting to work an IPTV decoder on a POST Bamboo access with a Mikrotik router instead of Fritz!Box has been one of my long time challenges that I never got around. But finally I got it done, here is how to reproduce it.

I used ether1 port on the Mikrotik to connect to the GPON network termination unit (NTU). As POST uses VLAN 35 as the transport VLAN, i created a vlan interface on top of ether1.

/interface vlan
add interface=ether1 name=ether1.vlan35 vlan-id=35

You will have to run the PPPoE session on top of this, but this post is about IPTV so let’s continue there. Next is to give the IPTV upstream port a source address.

/ip address
add address=10.10.10.10/24 interface=ether1.vlan35 network=10.10.10.0

This is the same IP address used by the Fritz!Box.

I dedicated ether8 port for the IPTV decoder. So you will have to add an IP address and DHCP server to that port.

/ip address
add address=192.168.188.1/24 interface=IPTV network=192.168.188.0
/ip dhcp-server
add address-pool=IPP-IPTV authoritative=yes disabled=no interface=ether8 lease-time=1d name=IPTV
/ip dhcp-server network
add address=192.168.188.0/24 gateway=192.168.188.1 ntp-server=%%%add IP address(es) of NTP server(s)%%%
/ip pool
add name=IPP-IPTV ranges=192.168.188.100-192.168.188.199

Please go to the NTP Pool to find ntp-server addresses.

Finally you will have to add an IGMP-Proxy that proxies from ether8 to ether1.vlan35

/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1.vlan35 upstream=yes
add interface=ether8

And that’s all you have to do. Enjoy.

Thanks to my friend David for the indispensable help.

This setup was realised on a POST Bamboo access line with a Routerboard CCR1009-8G-1S-1S+ running RouterOS 6.38. This setup is for “Mono VC” (mono virtual channel, or single VLAN) access lines only.

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

4 Comments

  1. Hi,

    I was wondering if you have tried skipping the NTU by using a mikrotik GPON ONT module ?
    Any idea if this might work in .lu ?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Yes tried it once very briefly, unfortunately I had no luck and it did not work out of the box. I have admit I just did a plug-a-see-what-happens test, I had no time to verify any specifics.

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  2. Hi,
    could you please check if on your side everything is still working?
    On my IPTV Box, the stream is still OK.
    But in VLC, i get the following:

    https://www.youtube.com/watch?v=ectzMlUVhH8
    Tested in Linux and Windows

    Thanks

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • The STP still works fine. I don’t have physical access to the network where I’m testing IPTV for the next few weeks.

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)

Leave a Reply

Get Adobe Flash player
%d bloggers like this: